Skip Main Navigation Skip To Navigation Content

Frequently Asked Questions

  ADA/508 friendly site



FAQ

American FactFinder: What are the browser requirements for American FactFinder?

American FactFinder does not support older browsers such as Microsoft Internet Explorer 7 and Mozilla Firefox 3.6. American FactFinder does not support compatibility view in Microsoft

 

American FactFinder supports common browsers. It was thoroughly tested up to the following versions: Microsoft Internet Explorer 11, Google Chrome 41, Mozilla Firefox 36, Apple Safari 5.1.

 

We recommend you upgrade to a newer browser. If you are using a newer browser, make sure you do not view American FactFinder in Compatibility View. Remove census.gov from Compatibility view in your browser settings.


(FAQ1585)

Was this answer helpful?